Jump to content
Sign in to follow this  
Vintersol

Vertical Thrusters

Recommended Posts

In a attempt to help me haul around cargo while mining I have built a storage barge with Hovers and Vertical Atmospheric Thrusters. My issue is that even when I am not inputting my craft to go up the vertical thrusters activate and attempt to hold me at a certain altitude just like the hovers when I just want the to be off unless I input to them to output thrust. It is a complete waste of fuel to be hovering via engines and not hovers so my question is how do I go about fixing this issue or changing things on my vehicle to make this work other then removing the thrusters entirely. Any feedback is appreciated.

Share this post


Link to post
Share on other sites
22 minutes ago, Vintersol said:

In a attempt to help me haul around cargo while mining I have built a storage barge with Hovers and Vertical Atmospheric Thrusters. My issue is that even when I am not inputting my craft to go up the vertical thrusters activate and attempt to hold me at a certain altitude just like the hovers when I just want the to be off unless I input to them to output thrust. It is a complete waste of fuel to be hovering via engines and not hovers so my question is how do I go about fixing this issue or changing things on my vehicle to make this work other then removing the thrusters entirely. Any feedback is appreciated.

You can use 2 different engine tags instead of the default "vertical" and then you replace the command on system.flush() that activates "vertical" with a if. If atmo <0.1 activate both tags, else, activate only the hover tag. 

Share this post


Link to post
Share on other sites

It wasn’t always like this. The current flight control script has nice features (hover height setting, for example) but it causes the craft to fly erratically if it has a lot

of lift, bobbing up and down and lowers the priority of the hover engines lower than that of vertical boosters - and worse - the atmospheric engines. 
 

My Lua-foo isn’t up to snuff yet so I’m not able to fix this particular issue without going back to an older script that I kept from a couple of alphas ago.   But this loses ALT-Space and ALT-C height control.

 

I had hoped there was a simple fix but it appears to require Lua. 

Share this post


Link to post
Share on other sites
1 hour ago, Vintersol said:

In a attempt to help me haul around cargo while mining I have built a storage barge with Hovers and Vertical Atmospheric Thrusters. My issue is that even when I am not inputting my craft to go up the vertical thrusters activate and attempt to hold me at a certain altitude just like the hovers when I just want the to be off unless I input to them to output thrust. It is a complete waste of fuel to be hovering via engines and not hovers so my question is how do I go about fixing this issue or changing things on my vehicle to make this work other then removing the thrusters entirely. Any feedback is appreciated.

I built a hauler speeder with hover engines and 1 atmo engine to move, I can show you on stream tomorrow morning. Weights 17t empty, can carry 150t+ cargo (that’s 4 S containers, 4 xs containers, plus inventory full) and can move at 600 km/h when full.
Twitch.tv/iorail

Share this post


Link to post
Share on other sites

Anyone know how to fix this? I spawned an old blueprint with 6 L hovers and 6 L vertical atmospheric engines. It used to hover nicely and just sip the glass but now the hovers don’t activate unless it is overloaded and it burns through its fuel in less than 30 minutes. 
 

basically it’s relying on 6 L atmos to hover and the Hovers are disables 95% of the time. 
 

 

why does NQ keep breaking things!? This used to work as expected. 

Share this post


Link to post
Share on other sites

I have a bugfix for it, and the code is below. Note that this works together with other code which automatically manage ground engines, e.g. set them to max altitude before landing. This code does not work alone. But I think you can test it by pressing Alt+Space/C

 

The idea is to get distance to ground, ground engine max altitude, and keep vertical atmos off until ship is over 90% of the max. There is small hesitation at max while verticals warm up.

 

The code is in system.flush, and the patch code goes around the part where vertical engines are handled. IIRC the first and last  comment are from default script, aiding to find the location. I hope they match current default script.

 

The code is clipped from flight script but had to edit heavily to get the gist of it.

Quote

  -- Vertical Translation
  local distanceToGround = 5 -- actually link a ground engine or
  -- telemeter and get the distance
  local groundCapability = unit.computeGroundEngineAltitudeStabilizationCapabilities()
  local maxHoveringAltitude = groundCapability[1]
  if distanceToGround > 0.4 and
   distanceToGround < maxHoveringAltitude * 0.9 then
    -- Bugfix: when landing verticals don't shut down even when ground engines take over.
    Nav:setEngineForceCommand("thrust analog vertical", vec3.zero)
  else
    ... -- here is the default script vertical engines code, twentysome lines
  end
  -- Auto Navigation (speed Control)

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...