Jump to content
Sign in to follow this  
krisstian

No access on Alpha Section of the forum

Recommended Posts

As my question in "The Arkship Pub" remains unanswered, I'm re-posting the question here, maybe it's more visible.

I'm trying since approx one week, without luck, to get access to the Alpha Section of the forum. :(

I'm backer - Patron, played the game, have access on Discord's NDA channels, yet forum section still unreachable.

I've sent email to support, asked in the support channel from Discord and I have a 7 days old ticket on the same topic.

I don't know what else I can do. Help?¬†ūüôŹ

Share this post


Link to post
Share on other sites
2 hours ago, Silentkills said:

have you tried logging out and back in? thats what i had to do to see nda forum posts.

Yep. Tried it (also disconnected all devices), multiple times, didn't worked .

 

31 minutes ago, NQ-Naerais said:

Please open a support ticket here so we can try figure out why you don't have access :)  support@novaquark.com  

Done also this. I have a ticket opened 7 days ago ( #17026) and email sent to support@novaquark.com on Friday afternoon.

 

Told you. I've done everything I could find & think of. :) 

My profile says " Member". I assume it should be "Alpha Tester" or similar.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...