Jump to content
Hagbard

Cross section calculation .. or how to fly faster..

Recommended Posts

Flying Faster with less
or
...Dual Universe and the cross section calculation

 

I quite enjoy building small efficient atmo flyers (you probably know the Hagboard)
The key to the fun factor of these little ships is keeping the Frontal Cross section as low as possible. For the Hagboard it is usually 0.38 which is the smallest value that is possible if you still want to have the comfort of a hover engine on your construct.
But since some months, DU is not making it easy for these little ships. There is a bad bug with the cross section calculation which usually leads to a wrong (higher) calculation of the frontal cross section.
You can easily see the problem by entering build mode and having a look at your max speed & frontal cross section. In most cases you first see lower speeds and a higher cross section, and after some additional seconds this value changes to the "real" values.
So the frontal cross section is supposed to be the total surface of the ship when looking from the front. This should be a static value, but due to the bug, we get 2 separate values.
Even worse: when starting a flight DU usually takes the "worse" value to calculate the flight physics.

I assume that the first "bad" calculation is done on the client side, and the second "real" values somehow come either from the server or using some values being loaded fro the server.
As sometimes the server is slow, we get into a situation where the "better" values might even never get loaded to the client.
As well during flight, DU re-calculates this values. So even if we manage to start a flight with the "better" values, we might get faster speed & Acceleration at first, but after some control movements DU usually falls back to the slow values.

There is 1 trick how you can do a test flight and "force" DU into the faster values.. give this a try:

1. place your construct flight ready, pointing towards a wide open area ( e.g. a big water surface)
2. enter build mode and look at your max speed / frontal cross section
3. wait for the max Speed & Cross section to be displayed with the "better" values
4. exit build mode and directly activate the seat/remote controller
5. give full throttle, avoid steering and try to stay between 100 and 300 m...

By following these steps you should be able to do a flight with the "full potential" of your construct.

Another possibility to increase the speed of your construct is to remove ALL Honeycomb from it. The cross section calculation only fails if there is at least 1 honeycomb voxel on your construct. so without them, it should always use the "better" values.

i have 2 tickets around this topic open now for 1-2 months, but obviously NQ has more important things  to fix right now. But as i get asked multiple times a day, i thought it would be easier to give the explanation here so i could point people to it 😉

Have fun flying,

Hagbard

 

 

Share this post


Link to post
Share on other sites

I haven't had an issue with the values changing,  they remain constant for me. However  my displayed speed does not seem to be correct. If I place a core and a large atmo engine only,  with thrust control and handling to 4, my displayed speed is about half of what I have seen on screenshots of fully constructed ships.  I have an alpha client that I have been patching, and I believe it it just a display bug because my speed is a lot higher than what it says. I'll post some exact values when I get home. Could you post your values on a basic large atmo engine and core only?  Maybe my values are the same as your low values.

My cross section and speed values are constant though.

 

BTW , I left you a blueprint in your donation box, and i was wondering if you tried it out. The name was Magic Missile Type A. I am sure you get a lot of blueprints, but I was just looking for some feedback. 

Share this post


Link to post
Share on other sites

here ya go..
xs core & basic l atmo with my main account talents..
image.png.23badfb8b27dea654d460fe11c890aed.png

and same with engine lvl 5 talents:
image.png.6e14505ce6776fc4170df4887e7f293b.png


Regarding the cross section bug, you'll probably only see it if you are working on xs elements with an ultra small cross section( like the hagboard)

 

Share this post


Link to post
Share on other sites
1 hour ago, Hagbard said:

here ya go..
xs core & basic l atmo with my main account talents..


and same with engine lvl 5 talents:



Regarding the cross section bug, you'll probably only see it if you are working on xs elements with an ultra small cross section( like the hagboard)

 

Thanks for that.  With  thrust control and handling at 4, I have 676 m/s speed  with a front cross section  of 14.0 . Are there any other talents that affect these values?

 

On the ship blueprint I mentioned,  it has a front cross section  of 1.13, and it still has constant values, and I don't notice any speed changes. Maybe  my client does the correct calculation all the time, but displays  incorrect information?

 

I have the v6 hagboard from alpha, when I get home I'll put one together and check to see if the values change.

Share this post


Link to post
Share on other sites

here is a quick video demonstrating the bug in build mode.
This constructs has 0.81m² and 0.38m² being displayed.. if you would finish this build, usually the 0.81 would get applied when flying, resulting in a much reduced top speed. ( unless you use the build mode steps i documented in the top post in this thread, to make the physiscs use the 0.38)

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...